Jeep Therapy Steering
[an error occurred while processing this directive] Short Cuts
[ Main Page | Intro | Disassembly | Frame | Axles | NV4500 | EFI 350 | Suspension | Suspension II | 350 Install | Brakes | Steering | Clutch ]

By: Jeep Layton - 1/2001



pshose1.jpg
After the Chevy and the Jeep hoses where spliced together, the hoses fit just right.
pshose2.jpg
A close up of the hoses spliced together. If you look close you can see the splice.
pshose3.jpg
Covered with the split loom, they look OEM.

Initially, I didn't think about this at all. But, trying to hook up the CJ power steering lines to the Chevy motor's power steering pump revealed a couple problems. First, they were too long & the wrong shape. Second, they had the wrong fitting on the end. I needed a power steering hose with a Chevy end and a Jeep end - essentially a "conversion" hose. I had both supply and return hoses from both the donor Chevy truck as well as the CJ. The return hose could be cut & spliced, as it was a low-pressure hose-clamp affair, but what about the pressure hose? Local hydraulic shops butchered my OEM hoses once - I didn't have enough tubing left to try a 2nd one. I needed a power steering hose shop.

Searching the web, I found Magill's. I sent them my marked-up chevy hose and marked up Jeep hose. The final result works well. My alignment marks still visible in the picture to the right. The second picture is a close-up of their quality workmanship. If you look closely and you can see the splice. With the Chevy donor-supplied split loom covering the hoses, you can't tell it's not an OEM piece.

Visible under the frame is the AGR Power steering box.


Related Information:

Trending on 4x4Wire TrailTalk Forums

New Topics on TrailTalk
Gen I 1989 Broken Hood Latch Solved!
by polar - 01/14/21 08:42 PM
torsion bar question
by tcb762 - 01/12/21 11:02 PM
‘89 Monty SWB - 1100 idle at start, -500 eventual
by BrooklynOpus - 01/04/21 03:14 PM
SOLD! New 1990-1995 Toyota 4Runner 4Dr Carpet
by code33 - 01/03/21 03:52 AM
Vet over his Head
by SATXGuy - 01/02/21 05:07 AM
KM145: What have I done wrong?
by TresMon - 12/28/20 05:45 PM
Recent Posts on TrailTalk
Gen I 1989 Broken Hood Latch Solved!
by polar - 01/14/21 08:42 PM
1989 Montero Broken Hood Latch Cable!
by polar - 01/14/21 08:40 PM
torsion bar question
by rxinhed - 01/14/21 02:07 AM
suzi the psychic
by rascott - 01/11/21 06:28 AM
Sway Bar delete.. ???
by Trailmonkey - 01/07/21 05:29 PM
Vet over his Head
by chadzeilenga - 01/04/21 03:56 PM
‘89 Monty SWB - 1100 idle at start, -500 eventual
by chadzeilenga - 01/04/21 03:51 PM







4x4Wire Social:

| 4x4Wire on FaceBook


OutdoorWire, 4x4Wire, JeepWire, TrailTalk, MUIRNet-News, and 4x4Voice are all trademarks and publications of OutdoorWire, Inc. and MUIRNet Consulting.
Copyright (c) 1999-2019 OutdoorWire, Inc and MUIRNet Consulting - All Rights Reserved, no part of this publication may be reproduced in any form without express written permission
You may link freely to this site, but no further use is allowed without the express written permission of the owner of this material.
All corporate trademarks are the property of their respective owners.